Tuesday, 29 December 2015

FAQ and Troubleshooter


Common problems

  • I can see the TacO icon and/or the Map Timer, but the icon won't do anything when I click on it, and doesn't highlight when the mouse is over it.
    • This can happen if GW2 TacO is running with lower privileges than GW2 itself. In this case the mouse input won't get transmitted to the application with the higher privileges. You most likely have GW2 running in admin mode (either you started it from an application that already had admin mode, or for other reasons like running Reshade) and GW2 TacO not. In this case running GW2 TacO in admin mode should fix the problem.
    • (Added a popup message to warn of this)
  • I can see the TacO icon and/or the Map Timer, but the rest of the screen is black and I can't play.
    • This can happen if you have the transparency effects turned off in Windows 7, probably because you're using the classic theme for Windows. Turning on Aero should fix the problem.
    • If you get this on Windows 8 or above on any TacO version above 008.513r please send me a dxdiag log so I can narrow down the problem.
    • Make sure you have the latest drivers installed for your GFX card, some people have reported the issue fixed with a driver update.
    • Make sure any driver related postprocesses (FXAA for example) are disabled for TacO. Those might fill the alpha channel with a fully opaque value and thus make TacO non-transparent.
  • I have GW2 running but I don't see the TacO icon in the top left or the Map Timer.
    • Check to see if you're running GW2 in fullscreen mode. Fullscreen mode is not supported by GW2 TacO as supporting that would mean entering a grey area that'd technically be against the game EULA. Run the game in Windowed or Fullscreen Windowed mode.
    • If you're not running the game in Fullscreen mode and still don't see anything, please contact me so I can debug the issue.
  • Everything works fine, but the TacO is over my PvP icon
    • Click the TacO icon and under Interface Size select the interface size that GW2 is set to.
  • How can I disable all the markers?
    • Click the TacO icon and untag the option that says "Tactical Overlay"
  • How can I disable some of the markers?
    • Click the TacO icon and from the very first menu you can toggle which types of markers you want displayed or not. You can click on higher level items in the menu to disable/enable everything below those elements.
  • I accidentally placed a marker with '+', how do I remove it?
    • Walk up to the marker and press '-'
  • Accented characters I type aren't working in GW2 when TacO is running.
    • This is a known issue. The way TacO acquires keyboard events (through what is called a low level keyboard hook) interferes with the pre-casting of accents that some keyboard layouts have. If this is bothering you to the point of not wanting to use the overlay I can put in an option to turn the keyboard handling off temporarily, let me know, but this request hasn't come up yet.
  • TacO doesn't keep my settings after I quit, and I need to set up everything all over again on each run.
    • This happens when TacO is put in a folder where it doesn't have write permissions without admin rights. Usually the cause of this is that you put TacO right next to GW2 inside the Program Files folder, which is something that requires elevated user rights for write access. Put TacO in a folder where it's certain to have write rights (the Desktop is a good solution for this), and the issue should be solved.
  • TacO works, but I don't see all the resource nodes in the game
    • TacO is only a platform, the information of where the nodes are is created by players since it takes a massive amount of work to mark everything. You can look around for marker packs that might have the information you're looking for, or help the community by creating your own and sharing it with others.
  • TacO behaves oddly when I use multiple GW2 accounts at once on the same PC
    • TacO is heavily based on the Mumble Link API. The problem you encountered is a limitation of this API: it was never designed to support multiboxing applications. It works by the GW2 client writing data into a specific memory mapped file, and TacO reading that data each frame. The problem is that when there are two or more GW2 clients writing to the same position, in the better case TacO will randomly fetch data from one of the clients, in the worse case the data itself will be a mangled mix of the data from several clients. This issue cannot be fixed without redesigning the Mumble API.

FAQ

  • Will using this get me banned?
    • Arenanet hasn't responded in any capacity to GW2 TacO yet, but they have made statements before that suggest that using it is ok. In particular they have said before, that using overlays is fine.
    • I intentionally avoid doing anything that even gets near the grey area of what could be deemed as a breach of the EULA. The camera information that is required to render the markers is acquired through the official Mumble Link API. Everything else displayed is user supplied content that is based on storing locations acquired manually from the data that the Mumble Link supplies. The overlay doesn't interact with the game in any other manner, it's simply a transparent window hovering above GW2. An example of something in the grey area (that I avoided implementing on purpose to stay away from even the grey area) would be making the overlay work in normal full-screen mode. This basically requires injecting code in the game, and is done by other overlays (anything that messes with shaders goes at least this far) or even Overwolf, but this latter is actually endorsed by Arenanet.
    • UPDATE: A video showcasing TacO was tweeted out by ArenaNet during the 2017 Super Adventure Box:
    • UPDATE: There has now also been a mention of TacO by one of the ArenaNet developers, stating that he doesn't see anything that would violate the fair use guidelines for the Mumble API.
    • tl;dr - using an overlay like GW2 TacO should not get you banned.
  • Is there a mac version?
    • No. TacO uses the Mumble Link API, which is not currently supported by the mac GW2 client. And even if that was fixed, TacO is built on DirectX, which is not available on mac. Because of this, and the size of the engine that TacO is actually built upon, porting would require significant effort. That would only be possible if I even owned a mac. But I don't.
  • Is this opensource?
    • Not at this time, no.
  • Why? Your development would be so much faster / I don't trust any non opensource homebrew software.
    • Why: Because the UI engine behind this overlay is something I've been working on for a couple years now, I use it in several other projects and it's not something that I want to opensource right now.
    • Developmend speed: Since I use a codebase completely written from the bottom up by me (I don't even use stl, and I supply my own functions for everything instead), anyone attempting to pitch in would have a LOT of catching up to do. This is a hobby project for me, released only because I think others can benefit from it. I'd like to avoid any sort of management tasks related to the overlay, which tend to pop up in any team effort.
    • Security: The debug information is in the archive (because I'm lazy and having that in there means any crash logs will have convenient line and file information), so it should be pretty easy for anyone that would understand the actual source code to take the overlay apart and see that it doesn't do anything malicious. If you're still not satisfied and you're a member of the opensource security zealot army, please let's just go our separate ways and stop wasting each other's time. If you don't trust it, don't use it.
    • A note: I did release some of the source code for the original tech demo after a lengthy debate on reddit, as an experiment. I didn't include the UI engine, but all of the technology used by the overlay (in regards to GW2) is in there. If you're wondering whether I'm accessing the client in any non EULA-friendly way, you can have a look at the released source code here.
  • I can see all the categories for the resource nodes and they are all ticked to be shown, but no nodes I saw were marked. What gives? Is TacO not working?
    • TacO in itself is mostly a tool for marking stuff in the game world. The marker packs that come with it were either created by me or donated by helpful players, and were the result of painful amounts of work in some cases (think the guild bounties). Creating and updating a marker pack containing all the possible spawn locations of all the nodes on all the maps is a HUGE undertaking, one that no one has been able to finish yet, and so TacO does not come with such a database. There are efforts under way to do this, we'll see how they go. The marker categories are there so you can mark stuff for yourself as you encounter nodes, so you can slowly build up your own database.

114 comments:


  1. I can see the TacO icon and/or the Map Timer, but the rest of the screen is black and I can't play.
    This can happen if you have the transparency effects turned off in Windows 7, probably because you're using the classic theme for Windows. Turning on Aero should fix the problem.

    If you get this on Windows 8 or above on any TacO version above 008.513r please send me a dxdiag log so I can narrow down the problem.


    I have this problem, but i'm on windows 10, any solution yet ?

    ReplyDelete
  2. How can I disable the "BigMarker" icon that I think appears near the start of things? There's one near the start of Super Adventure Box in Rata Sum, and it's really annoying.

    ReplyDelete
    Replies
    1. If it's a big yellow diamond shape, that's the default icon that's placed if you press +
      If you accidentally placed one, you can remove it by standing on it and pressing -

      Delete
  3. Hello,
    first thank you for this great tool.
    I would like to signal a minor bug. the international US setting for keyboard do not work properly with gw2 when TACO is on, some key like 'or ` do not respond or act weird. i am french with a qwerty keyboard instead of an azerty so i use thoses keys to make accents and apostrophes (like '+e=é or l+'+space=l').
    Like i said it is not a big bug but it is still annoying because i have to close the overlay everytime i need to use the black lion or type something specific. could there be a way to fix this?
    Have a nice day.

    ReplyDelete
    Replies
    1. Same bug here with an azerty layout when I try to combine "^" and "e" to do "ê" it either print "^^e" or just "e"

      It works fine when I stop gw2taco

      Delete
    2. it would be nice to have an option to turn the keyboard handling off, I don't think I'm using it, so if it's causing this bug...

      Delete
  4. Which build can i use in Windows XP x64?

    ReplyDelete
    Replies
    1. None. TacO uses DirectX 11 which is not available on Windows XP.

      Delete
  5. First of all, thank you for this, it's a really nice project that i think deserves attention and support (the range display is pure genius!).
    Now, for some reason the markers keybinds don't seem to work and i wasn't able to change them either, except it would only accept Escape and Enter inputs when trying to edit the default keys (which i don't really want to bind obviously). Any possible explaination for this? Running on Windows 7 64 bit, both game and overlay in admin mode.

    ReplyDelete
    Replies
    1. Nevermind, i kinda managed to make it work: if i alt-tab to gw2taco i can add-remove-edit markers now, is that how it's supposed to work?

      Delete
    2. No, that's odd. It probably has to do with the keyboard handling issues that I still didn't have time to look into.

      Delete
    3. I'm having this problem too. ESC, Enter, Enter (numpad), and Backspace only work for binding or work at all in GW2TaCo. I'm not able to alt-tab into GW2TaCo since it doesn't show up as a window that can be tabbed in to.

      Windows 7 64 bit as well. Really frustrating, please try and fix it :)

      Delete
  6. Hey BoyC, Need some help here. Recently I downloaded your overlay and installed it onto my desktop. After following your instructions I am still having issues with it. It turns my screen black and condenses all the bars icons etc to the upper left corner of my screen. Ive tried both windowed modes and checked (and updated drivers)Nvidia anti aliasing settings to ensure no issues there as well. Can we set up a time to teamspeak and troubleshoot whatthe issue is by chance? Let me know please!

    ReplyDelete
    Replies
    1. Well... its been 15 days and no reply... since you have no interest in helping me resolve my issue, I guess I will just move on.... found a better overlay anyways its with the gw2 timer folks, its called GW2 Navi and its at
      http://forum.renaka.com/topic/5546166/1/

      Delete
    2. Sorry you feel that way. I told you twice ingame to send me an email, which never happened. These comments are hard to keep track off, and my free time to work on TacO is limited, this being a hobby project and all. Have fun with the other overlay.

      Delete
    3. So you don't get email notifications of posts sent to you on your website? I did not send the email because I figured speaking to you on your trouble shooting page would be sufficient. Also I don't like giving my email out to everyone as well. I figured that since you replied to others on this post area, that I would be able to talk to you here.
      Yes I'm sorry it didn't go well either. I kept anticipating its use, and seeing you post replies to everyone else, so I just went elsewhere.

      Delete
    4. I do get mails from here. It's a single messy stream of random that's not fit for any debugging communication. I already spent weeks on the 'black screen' bug and have listed all known causes on this page. This is not the proper forum to handle a possibly 10-20 hour debugging session.

      Delete
  7. Looks like GW2Taco is broken with the latest GW2 release

    ReplyDelete
    Replies
    1. Could you elaborate on that? Works just fine for me.

      Delete
    2. What info do you require from me?

      Delete
    3. A description on HOW it is "broken" would be a start :P

      Delete
    4. Taco randomly freezes somethimes after 2min. or if i tab out.

      Delete
    5. Hey BoyC, I think we have our wires crossed... I think I accidently posted in his post, mines the one above it. I'm still trying to get it running in the first place. can you please contact me so we can work this out?

      Delete
  8. The Marker editor opens and then disappears straight away. Any solution to this? My tactical display is toggled on.

    ReplyDelete
    Replies
    1. The marker editor is set to auto hide when you're not standing on a marker. To set the default values just place a temporary marker or walk to an existing one.

      Delete
    2. Markers wont place either. Also the marker editor only opens when my tactical display is set to off. Then when I turn it on, it disappears and still no markers.

      Delete
    3. ^^^^^ Oops sorry that was still me, just forgot to add the name

      Delete
  9. Okay I have it working, you were correct, I figured it out. Thank you!

    ReplyDelete
    Replies
    1. Lol I am horrible at using this site, you can clean up my mess if you wish xD

      Delete
  10. I really like the concept of your add on, and the tactical display has some great benefits.... BUT you cannot turn off some of the parts of it. specifically the markers that are extremely obnoxious in Lions arch.Seriously can we get a way to turn these off? I only want the raid markers, not the random markers all over lion's arch and toggling the whole tactical display on/off to get rid of them every time is kind of annoying

    ReplyDelete
    Replies
    1. The same markers are also present on some maps for IDK what reason but even with EVERY single tactical display sub choice toggled off they still appear..... They are the stupid orange diamonds with a lighter bottom half, why are they there?

      Delete
    2. The diamond shaped markers are default markers that you must have placed by pressing +. You can rebind the + key to somewhere else. To delete all markers you might have placed simply delete the poidata.xml.

      Delete
    3. thank you, i guess ill set it to a key i will never use again. Definitely fixes with my issue with it, would be a cool to get a option to turn them off though, like all the other tactical markers.

      Delete
  11. Hey guys, i'm using an pc with windows 10 (with two screens), NVIDIA GTX 650. Every time i try to run Tacos it freezes at about 2 min. I've tryed to updade my GTX, direct and tacos, but the problem persists. Is there something that i could do to fix it? Thank you very much, have a nice day !

    ReplyDelete
    Replies
    1. I'm looking into that issue as we speak.

      Delete
  12. Its a great overlay; thank you for making it.
    I encountered one problem: i cant type accents anymore when i am using taco. They dont appear or you get something like 'a.

    ReplyDelete
    Replies
    1. It's an issue with the way I handle keyboard stuff. I'm actively looking for a better way of doing so and the next build might get better in this regard already. How do you write accented letters? Do you need to press alt to write them?
      Also, did earlier builds also cause this issue?

      Delete
  13. How do i disable the karma icons on the screen, they are annoying and they keep blinking.

    ReplyDelete
    Replies
    1. Uncheck the festival icons in the TacO menu.

      Delete
  14. Im having the Win10 black screen issue as well. I can only see the taco icon and the event map overlay. How do I contact ya and send the DxDiag file?

    ReplyDelete
    Replies
    1. Ok, so basically I had to change the settings for my Nvidia graphics card to include "off" for multiple settings, including FXAA, Gamma correction...etc. Also, I changed the Antialiasing (Transparency) to its highest option. My game crashed and I had to reboot b/c even taskmgr was broke. Then, when I opened my game I basically turned everything off there. Now the overlay looks normal as someone demonstrated in a Youtube video.

      Delete
  15. https://virustotal.com/hu/file/0665bd4b402a42a2377811d84f32538971e18f949e2b42375622d8bb077ca18f/analysis/1482582379/

    Trojan Inject...?! GG

    ReplyDelete
  16. You are only using GW2 API informations and no memory informations ?

    ReplyDelete
    Replies
    1. Yes. That's one of the core principles behind TacO.

      Delete
  17. other way: where are from the informations that you use? important is that you dont use informations from gw2 memory storage!

    ReplyDelete
    Replies
    1. All real-time information comes from the client through the official Mumble Link API built into the GW2 client. The locations of the markers have been stored by users of TacO (by storing data TacO gets through the Mumble Link) and are supplied in data files with the overlay. So the realtime camera data and character position are gathered through an official API, the marker locations and marker icons are user generated data. TacO doesn't touch any part of the GW2 client memory, not even the screen buffer. TacO doesn't touch the GW2 data file, not even to fetch icons. TacO doesn't track GW2 communications in orther to gather information. TacO doesn't hook into the directx dlls to display the overlay (as a result of this it's not available in fullscreen mode).
      What TacO does is to ask Windows where the window called "Guild Wars 2" is, asks the GW2 client through the official Mumble Link API where the camera and player are in the game world, and then draws a transparent window above the GW2 window with 3D markers.

      Delete
    2. imean:EULA §8i:
      "(i) Use, obtain or provide data related to operation of the Game, including but not limited to:

      (i)software that reads areas of computer memory or storage devices related to the Game;

      (ii)software that intercepts or otherwise collects data from or through the Game;

      (iii)software that redirects communications from any Game or Service; or

      (iv)software not provided by ArenaNet which creates or maintains any communication to the Game or Service, including but not limited to any software that emulates the Game or any part thereof as well as any server that emulates the Service or any part thereof;"

      Delete
    3. TacO does none of that.

      Delete
  18. Hi, i have a resoloution of 3840x2160 on my screen and when i tag the raidbosses the hp lines are basicly on the breakbar or under, and there is no smaller interface, is that something that will be fixed or am i doing something wrong?

    ReplyDelete
    Replies
    1. You need to disable display scaling on high DPI settings in windows, you can do it for TacO if you create a shortcut for it.

      Delete
    2. i'm sry for my, i'm not the brightest computer guy, could u try explain how :)?

      Delete
    3. Create a shortcut for TacO in windows. Once it's done and working, right click on it, select properties, go to the compatibility tab in the new window and check "Disable display scaling on high DPI settings".

      Delete
    4. "in windows"? Does that mean just to create a shortcut anywhere? I tried creating a shortcut for taco in my desktop and disable scaling on high dpi settings on that shortcut, but that didnt work. Should i edit the original, or did i get this "creat a shortcut in windows" wrong?

      Delete
    5. Uh. You know what, it might actually be less of a headache for me to look into making TacO dpi aware than trying to debug this over the comments. I'll look into it. If I can make it work, expect a new build tonight.

      Delete
    6. I'm sry, it did work, thx for that :D! I'm wondering though if it works to make gw2 look bigger with skills and such and still have highres? i'm running "larger" interface atm (still too small), but disabeling stuff in gw2 shortcut worked no magic for me.

      Delete
    7. That's because gw2 is already dpi aware. The next build of TacO will be as well (fix is done), but if you have it already working I won't rush out a new build just for this.

      Delete
  19. Hello,

    I was using GW2Taco while at Sabetha tonight and I noticed that the timers it displays for cannons when they spawn were off by 10 seconds. Not sure if this is anything on my end or not...

    ReplyDelete
  20. This comment has been removed by the author.

    ReplyDelete
  21. Hey,

    I'm having an issue where if i turn the overlay on it makes everything on my computer basically framelimited to 30 fps

    ReplyDelete
  22. Hi I am having an issue where all custom packs are showing as bigmarker.png with a select few at seemingly random working correctly. I also cant disable the big markers without closing the program.

    ReplyDelete
    Replies
    1. Same for me, tried a custom pack for SAB, tried a few things like moving markers to both DATA folders (main one and the one inside POI). Any idea?

      Delete
  23. I have an issue when I am alt-tabbing. Whenever I alt-tab back to GW2, taco is not appearing on top. It's still running, I can see the icons on desktop when I change to window mode (kinda like turning into "underlay" instead of overlay).

    I have to fully restart my game to make it normal. Even that is a temporary fix, it will break again once I alt-tab. Is there any other solution for this?

    ReplyDelete
  24. This comment has been removed by the author.

    ReplyDelete
  25. Hi, first of all thank you for creating this overlay! I'm mainly using this for Silverwastes chest farm, I installed it according to the quick start guide, everything looks great, taco icon aligned checked, clickable checked, could mess with menu checked, but when I went to Silverwastes, I can't seem to find any markers for any chest, what am I doing wrong? And when I try to add a custom marker on a dirt mount a found for a chest, nothing happens on the screen. Please help! Thanks!

    ReplyDelete
    Replies
    1. I derped it! I didn't get the LATEST version...I just went from the page on this website detailing the addition of Silverwaste chest to the overlay instead of downloading from the right per the instruction :P My bad! Excellent addon, thank you again for your time and effort!

      Delete
  26. Hi, first of all thank you for creating this overlay! I'm mainly using this for Silverwastes chest farm, I installed it according to the quick start guide, everything looks great, taco icon aligned checked, clickable checked, could mess with menu checked, but when I went to Silverwastes, I can't seem to find any markers for any chest, what am I doing wrong? And when I try to add a custom marker on a dirt mount a found for a chest, nothing happens on the screen. Oh and overlay is turned on, I checked! Please help! Thanks!

    ReplyDelete
    Replies
    1. I derped it! I didn't get the LATEST version...I just went from the page on this website detailing the addition of Silverwaste chest to the overlay instead of downloading from the right per the instruction :P My bad! Excellent addon, thank you again for your time and effort!

      Delete
  27. Hi. Thanks for great tool!
    Is there any way to disable zoom for markers when you approach to them?

    ReplyDelete
  28. Hi, is there a way to change the text timers that appear during raids? For example, instead of it saying 'SOUTH CANNON in 15' I would like it to say 'ARROW CANNON in 15' relating to my markers. Is it just a matter of rewording it in the locationaltimers.xml?

    ReplyDelete
    Replies
    1. Yeah just change the text and that's it. It's all data-driven.

      Delete
    2. I tried and when I edit the text and save the file out again it stops displaying any timers. Is there something else I need to do, or something special I need to open or save it with or something? I tried editing it with notepad, and an xml editor

      Delete
    3. Edit the text when TacO is not running and when you saved it, launch TacO.

      Delete
    4. I had TacO closed but I got it to work now, I closed the game as well and after relaunching the game and TacO it was fine. Thanks for the help :)

      Delete
  29. "Accented characters I type aren't working in GW2 when TacO is running. | If this is bothering you to the point of not wanting to use the overlay I can put in an option to turn the keyboard handling off temporarily"

    Yes please, this is really getting in my way of typing a lot, I am usually very active in guild chat and in whispers, so typing without apostrophes for example can really mess with my messages :)

    Thanks in advance!

    ReplyDelete
  30. When using the overlay everything on screen is black except the overlays themselves. Even the launcher for the game can't be seen if I start the program before GW2. Any fixes?

    ReplyDelete
    Replies
    1. If the solutions under the common problems part of this article aren't working, then no, currently I don't know the source of the issue.

      Delete
    2. Thank you for the quick response. Indeed turning on an Aero theme solved the issue. However, I did not see the details in the FAQ at the time of the question. Guess I did not look well enough. Regardless, if, in the future, somehow you will be able to make it work without Aero, it would be a tremendous help. Due to the fact that I am running the game on a 2010 laptop, I do not use aero as I want as much performance as possible squeezed. Between the program itself, TACO and aero I barely get 12-13 constant FPS. Without aero it jumps me at around 20. All of this said just for the sake of the information and future optimization IF there is a demand. Thank you again and keep up the good work! Cheers!

      Delete
  31. Hi there. i really like your software but sadly it's having some interference with the MSI Afterburner/Rivatuner OSD. I could imagine this being just in the nature of it but if you can fix that, it would be awesome. this is how it looks: http://imgur.com/a/284OI

    ReplyDelete
    Replies
    1. That's a known issue with DPI scaling in newer Windows systems that should be fixed with the next build. In fact I wrote the code to fix that today :) (Or you just didn't set the interface size in the TacO menu to correspond to what your in-game setting is, something that should also be automatically done with the next release, I'm waiting for an API update in the GW2 client that will allow TacO to do this)
      A temporary fix for the DPI stuff would be to make sure your Windows scaling is at 100% and not above.

      Delete
    2. Scaling in Win10 is at 100%, all visual effects are on and i now tried setting tacos interface size to the same as i had in game (small) but that didn't change anything sadly. the interface size settings don't change anything about the Afterburner OSD. If i turn taco off or switch to exclusive fullscreen, the OSD goes back to normal. the issue also persists if i switch the OSB to vector 2D or raster 3D rendering

      Delete
    3. OSD, not OSB ^^

      also: i wouldn't want to have taco set to small. that makes taco almost unreadable on my monitor. i've got the game UI on small and TacO on large to achieve about the same font size

      Delete
    4. Oh, I see now what's happening: since TacO is also a directx application, your OSD also renders onto that window. If there's any way to exclude TacO from your other overlay, that should fix your problem.

      Delete
    5. yes! that fixed it ^^
      if you want to add that to the FAQ you can tell people to:
      -open Rivatuner
      -click the big plus (+) icon
      -navigate to where GW2TacO.exe is located and select it
      -set application detection level to "none"
      done

      Delete
  32. Hi! I saw WP's video on your tool and thought I'd try it out but I can't find the TacO icon in the upper left. It is not overlapping with any of the other icons. I AM in windowed fullscreen mode. The only thing I can see is a bunch of dots on the far right of my screen above the minimap, which are also visible when I am tabbed out of GW2.
    http://imgur.com/a/T6NoS

    ReplyDelete
    Replies
    1. Wow, that's a new one. I suspect it might have to do with some DPI scaling issues we had recently that will be fixed in the next build. The markers you see are partially for the JP in the bottom right of LA, if you could go through it and look for changes in the pattern it might help determine what's wrong.

      Delete
    2. (This time the dots were slightly farther up on the screen)
      Going through the JP occasionally a lighter marker would move to the middle of the rectangle where the dots seem to be limited to. I would agree with your assumption of it being a scaling error.

      I tried setting my game to fullscreen mode and switching back to see if that helped anything, but it still looked the same. While in fullscreen mode, if I alt-tabbed there would be a split second where the dots seemed to be properly scaled on a black screen, then they went back to their rectangle (still visible outside of the game).

      Delete
    3. Would you by chance have any other window open that's titled Guild Wars 2? Maybe an explorer window or something open in the gw2 folder? That might confuse the overlay easily.

      Delete
    4. As far as I can tell, there are no other windows titled Guild Wars 2.

      Delete
    5. That whole thing is just odd. There is no sign of the TacO menu icon either, but stuff is obviously being drawn.
      Do you have a multi-monitor system or some odd resolution or something? Maybe a dxdiag would help with some info.

      Delete
    6. I'm on a laptop, so only one monitor, resolution is 1920x1080. As for the DxDiag text file, how should I send that to you?

      Delete
    7. Here: https://gist.github.com/OrigamiPie/77b77f101f6e1b1b29aae1c4f2c8d934

      Delete
    8. Hm. Well the system DPI is 125%, that shouldn't show this high amount of artifacts, but you might want to try it at 100% (this is something the next build will fix btw)
      Long shot, but it might also be that for some reason TacO isn't running on the nvidia gpu, but why that'd cause a problem, I'm just guessing.
      Other than this, I don't know. I guess I'll need to put in a debug function to the overlay to be able to have a look at this and other issues.

      Delete
    9. Tried switching it to run on the GPU, no change. Changed DPI scaling to 100%, no change. Switched TacO back to Cpu with dpi now at 100%, no change. :/

      Delete
    10. In this case I'll create a debugger functionality when I have some time to look into this. But not tonight, it's almost 1 am here and I have work tomorrow :)

      Delete
    11. The latest version seems to have not changed the issue

      Delete
  33. This comment has been removed by the author.

    ReplyDelete
    Replies
    1. You have something bound to your '+' key, you can rebind it in the TacO menu so it doesn't place markers :) You can remove already placed such markers by standing on them and pressing '-'

      Delete
  34. On the most recent build (as of july 13th 2017), on a default install, no markers are showing up other than the ones in the Silverwastes for chests above and underground.

    All markers are enabled. Gw2 is fullscreen windowed, and I'm not sure what else I can do to fix this.

    ReplyDelete
  35. This comment has been removed by the author.

    ReplyDelete
  36. I downloaded the most recent build and run in fullscreen windowed. When I tried the compass and range markers the center was off-set to the bottom right corner between the end of my skill bar and my mini-map. This makes the range markers useless for me. Also when I look up the compass disappears entirely off screen (shifts downward out of view). Not sure what would fix this.

    ReplyDelete
    Replies
    1. Possibly the next build will if it's a DPI scaling issue. Expect it during the weekend, I'm still working on stuff.

      Delete
    2. Thank you very much for all your hard work. I really appreciate it!

      Delete
  37. Hello. Downloaded it today and it worked fine for a few hours. Then when I started getting ready for raids the icons jumped from GW2 to my second monitor. Restarting it doesn't work but restarting the game does. Within a matter of minutes the icons move again to the second monitor. I'm not sure what's causing it.

    ReplyDelete
  38. Downloaded, installed and rebooted only to find out the .exe crashes each and every time I open it.

    I am running Win 10 - so if there's anything I need to do to get it to work, let me know, please.

    Thanks!

    ReplyDelete
    Replies
    1. If it crashes, a crash.log should have been generated next to the executable. Send that to boyc [at] scene [dot] hu along with any other .log files that have been generated and I'll take a look.

      Delete
  39. I noticed some of the markers in silverwastes for chests are missing. Is there a way I could place markers in the missed spots?

    ReplyDelete
    Replies
    1. There's a guide on how to create your own marker packs (http://gw2taco.blogspot.hu/2016/01/how-to-create-your-own-marker-pack.html), that explains how you can place your own markers. If you find some unmarked chest locations, I'd be grateful if you sent over an updated pack.

      Delete
  40. I have a Gsync monitor, and TACO disables G-SYNC :( I think its because the monitor thinks i'm running a still image (taco) instead of the game. I can't use it as playing without g sync is so annoying :(

    ReplyDelete
    Replies
    1. TacO isn't rendering a still image, but it does use the same techniques that a game engine does to render. I'm not closely familiar with G-Sync, but does it support two hw accelerated applications running at once?

      Delete
  41. Hello,

    try to use TacO but i see nothing. No Icon, no markers. Tried a lot read the comments, but didnt understand why. Taco.exe runs with gw2 over nvidia gpu, use windowed Fullscreen, also tried windowed. Task manager say Taco runs but nearly no cpu usage. Dont know the problem, pls help. Use win1o . Thx Pug

    ReplyDelete
  42. Hey BoyC Thanks a lot for your work on this awesome tool, bro I'd like some help with and issue in-game, TacO runs, but I can't see the resource nodes while Im playing :/

    ReplyDelete
    Replies
    1. Updated the common problems section.

      Delete
  43. Hi BoyC, GW2TacO is pretty Great! one request though, I'm on a European Server(Whiteside Ridge) and your world boss timers are about an hour out of sync with when they actually happen for me. (actually the only Timers I've found that actually are accurate are the ones found at guildwarstemple.com/dragontimer) is there any chance of getting an option to adjust the timers included in GW2TacO?

    ReplyDelete
  44. Is there no way to get TacO to work on Windows 7 with the classic theme? I can't stand aero.

    ReplyDelete